Uploaded image for project: 'Onyx'
  1. Onyx
  2. ONYX-186

Cannot modify participant's phone number

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0
    • Component/s: None
    • Labels:
      None

      Description

      1) Receive participant "John Hudson" with birthdate "1970-05-26"
      2) In the participant search page, click on edit (next to the participant)
      3) Edit the phone number field (enter a phone number)
      4) Press save
      5) Click OK on the weird confirm windows that pops up

      You will get the following crash:

      WicketMessage: Error calling method: public void org.obiba.onyx.core.domain.participant.ParticipantAttributeValue.setData(org.obiba.onyx.util.data.Data) on object: org.obiba.onyx.core.domain.participant.ParticipantAttributeValue@15b2386

      Root cause:

      java.lang.IllegalArgumentException: DataType null expected, TEXT received.
      at org.obiba.onyx.core.domain.participant.ParticipantAttributeValue.setData(ParticipantAttributeValue.java:112)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.apache.wicket.util.lang.PropertyResolver$MethodGetAndSet.setValue(PropertyResolver.java:1093)
      at org.apache.wicket.util.lang.PropertyResolver$ObjectAndGetSetter.setValue(PropertyResolver.java:583)
      at org.apache.wicket.util.lang.PropertyResolver.setValue(PropertyResolver.java:137)
      at org.apache.wicket.model.AbstractPropertyModel.setObject(AbstractPropertyModel.java:164)
      at org.apache.wicket.Component.setModelObject(Component.java:2889)
      at org.apache.wicket.markup.html.form.FormComponent.updateModel(FormComponent.java:1069)
      at org.apache.wicket.markup.html.form.Form$20.validate(Form.java:1837)
      at org.apache.wicket.markup.html.form.Form$ValidationVisitor.formComponent(Form.java:165)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:421)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:408)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:408)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:408)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:408)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:408)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:408)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrder(FormComponent.java:385)
      at org.apache.wicket.markup.html.form.Form.visitFormComponentsPostOrder(Form.java:1060)
      at org.apache.wicket.markup.html.form.Form.internalUpdateFormComponentModels(Form.java:1829)
      at org.apache.wicket.markup.html.form.Form.updateFormComponentModels(Form.java:1796)
      at org.apache.wicket.markup.html.form.Form.process(Form.java:865)
      at org.apache.wicket.markup.html.form.Form.onFormSubmitted(Form.java:807)
      at org.apache.wicket.ajax.form.AjaxFormSubmitBehavior.onEvent(AjaxFormSubmitBehavior.java:120)
      at org.apache.wicket.ajax.AjaxEventBehavior.respond(AjaxEventBehavior.java:163)
      at org.apache.wicket.ajax.AbstractDefaultAjaxBehavior.onRequest(AbstractDefaultAjaxBehavior.java:297)
      at org.apache.wicket.request.target.component.listener.BehaviorRequestTarget.processEvents(BehaviorRequestTarget.java:100)
      at org.apache.wicket.request.AbstractRequestCycleProcessor.processEvents(AbstractRequestCycleProcessor.java:91)
      at org.apache.wicket.RequestCycle.processEventsAndRespond(RequestCycle.java:1175)
      at org.apache.wicket.RequestCycle.step(RequestCycle.java:1252)
      at org.apache.wicket.RequestCycle.steps(RequestCycle.java:1353)
      at org.apache.wicket.RequestCycle.request(RequestCycle.java:493)
      at org.apache.wicket.protocol.http.WicketFilter.doGet(WicketFilter.java:355)
      at org.apache.wicket.protocol.http.WicketFilter.doFilter(WicketFilter.java:200)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.springframework.orm.hibernate3.support.OpenSessionInViewFilter.doFilterInternal(OpenSessionInViewFilter.java:198)
      at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
      at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
      at java.lang.Thread.run(Unknown Source)

      Complete stack:

      org.apache.wicket.WicketRuntimeException: Error calling method: public void org.obiba.onyx.core.domain.participant.ParticipantAttributeValue.setData(org.obiba.onyx.util.data.Data) on object: org.obiba.onyx.core.domain.participant.ParticipantAttributeValue@15b2386
      at org.apache.wicket.util.lang.PropertyResolver$MethodGetAndSet.setValue(PropertyResolver.java:1097)
      at org.apache.wicket.util.lang.PropertyResolver$ObjectAndGetSetter.setValue(PropertyResolver.java:583)
      at org.apache.wicket.util.lang.PropertyResolver.setValue(PropertyResolver.java:137)
      at org.apache.wicket.model.AbstractPropertyModel.setObject(AbstractPropertyModel.java:164)
      at org.apache.wicket.Component.setModelObject(Component.java:2889)
      at org.apache.wicket.markup.html.form.FormComponent.updateModel(FormComponent.java:1069)
      at org.apache.wicket.markup.html.form.Form$20.validate(Form.java:1837)
      at org.apache.wicket.markup.html.form.Form$ValidationVisitor.formComponent(Form.java:165)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:421)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:408)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:408)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:408)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:408)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:408)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrderHelper(FormComponent.java:408)
      at org.apache.wicket.markup.html.form.FormComponent.visitFormComponentsPostOrder(FormComponent.java:385)
      at org.apache.wicket.markup.html.form.Form.visitFormComponentsPostOrder(Form.java:1060)
      at org.apache.wicket.markup.html.form.Form.internalUpdateFormComponentModels(Form.java:1829)
      at org.apache.wicket.markup.html.form.Form.updateFormComponentModels(Form.java:1796)
      at org.apache.wicket.markup.html.form.Form.process(Form.java:865)
      at org.apache.wicket.markup.html.form.Form.onFormSubmitted(Form.java:807)
      at org.apache.wicket.ajax.form.AjaxFormSubmitBehavior.onEvent(AjaxFormSubmitBehavior.java:120)
      at org.apache.wicket.ajax.AjaxEventBehavior.respond(AjaxEventBehavior.java:163)
      at org.apache.wicket.ajax.AbstractDefaultAjaxBehavior.onRequest(AbstractDefaultAjaxBehavior.java:297)
      at org.apache.wicket.request.target.component.listener.BehaviorRequestTarget.processEvents(BehaviorRequestTarget.java:100)
      at org.apache.wicket.request.AbstractRequestCycleProcessor.processEvents(AbstractRequestCycleProcessor.java:91)
      at org.apache.wicket.RequestCycle.processEventsAndRespond(RequestCycle.java:1175)
      at org.apache.wicket.RequestCycle.step(RequestCycle.java:1252)
      at org.apache.wicket.RequestCycle.steps(RequestCycle.java:1353)
      at org.apache.wicket.RequestCycle.request(RequestCycle.java:493)
      at org.apache.wicket.protocol.http.WicketFilter.doGet(WicketFilter.java:355)

        Attachments

          Activity

          mboulang Martin Boulanger added a comment - - edited

          This seems to work with any participant that was imported without a phone number. The simplest way to reproduce the problem is by deleting the phone number of any user in the appointment list excel file, before calling the update procedure from Onyx web interface.

          hudson Jenkins Continuous Integration Server added a comment -

          Integrated in Onyx #1285 (See http://132.204.211.183:8080/hudson/job/Onyx/1285/)
          :
          Fixed on trunk

          mboulang Martin Boulanger added a comment -

          Tested in simulation room.


            People

            • Assignee:
              dspathis Dennis Spathis
              Reporter:
              mboulang Martin Boulanger
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Due:
                Created:
                Updated:
                Resolved: